GM B-Body Forum, 77-79 Caprice/Impala Forum

Join Now If Your A 1977- 1979 Caprice or Impala owner or other GM B-Body owner!!!
Like us on Facebook https://www.facebook.com/BBodyForum?ref=hl
GM B-Body Forum, 77-79 Caprice/Impala Forum

A forum for all the owners and enthusiasts of General Motors B-Bodies from 1965-1996, but dedicated to the owners of 1977-1979 Impalas and Caprices. Join up now!


    Cooling Air lock

    Share
    avatar
    Myloth
    Forum Moderator

    Posts : 628
    Join date : 2014-06-09
    Location : At the base of the Mountain (NY) Adirondacks

    Cooling Air lock

    Post  Myloth on Thu Apr 09, 2015 4:12 pm

    I can't seem to get air out of the cooling system. I tried running with and without cap and elevating the front end with no luck anyone ever have this problem? And the thermostat is working fine.

    And there is no coolant reaching the heater core I also tried with and without heat on. If I leave the cap off the coolant eventually backs out of the radiator some rather than going down, temps go to about 210.
    avatar
    Sweet Seventy9
    Forum Moderator

    Posts : 955
    Join date : 2013-11-03
    Location : Upstate NY

    Re: Cooling Air lock

    Post  Sweet Seventy9 on Thu Apr 09, 2015 5:49 pm

    water pump


    _________________
    1977 Impala Landau x1
    1977 Caprice Coupe x3, Sedan x3
    1978 Impala Landau x1, Sedan x2, Station Wagon x1
    1978 Caprice Landau x1, Caprice Coupe x2
    1979 Impala Coupe x2
    1979 Caprice Coupe x7, Landau x4, Estate Wagon x1
    1981 Impala Coupe x1
    1983 Impala Sedan x1
    1983 Caprice Sedan x1
    1984 Caprice Landau x1, Sedan x1
    1985 Caprice Coupe x1, Landau x3, Sedan x4
    1986 Caprice Coupe x1, Landau x1
    1987 Caprice Landau x1, Sedan x4
    1989 Caprice Sedan 9C1 x4
    avatar
    Myloth
    Forum Moderator

    Posts : 628
    Join date : 2014-06-09
    Location : At the base of the Mountain (NY) Adirondacks

    Re: Cooling Air lock

    Post  Myloth on Thu Apr 09, 2015 6:53 pm

    Well this the replacement (used it seemed to spin ok but ) for the prior one that made noise. Yeah could be if it is that

    sucks but I never had this problem before with a good pump so ........ Oh well I guess I'll have to use the new HD aluminum

    I was saving .
    avatar
    Myloth
    Forum Moderator

    Posts : 628
    Join date : 2014-06-09
    Location : At the base of the Mountain (NY) Adirondacks

    Re: Cooling Air lock

    Post  Myloth on Fri Apr 10, 2015 4:11 pm

    Sweet you were dead on except the pump wasn't bad I forgot to pull the plug out. Damn I guess I was a little

    too quick lol.

    The punchline I it ran for 3 min then the pump started making noise and weeping sigh. Should of just put in

    the new one and been done.

      Current date/time is Sun Oct 22, 2017 12:46 am