GM B-Body Forum, 77-79 Caprice/Impala Forum

Join Now If Your A 1977- 1979 Caprice or Impala owner or other GM B-Body owner!!!
Like us on Facebook https://www.facebook.com/BBodyForum?ref=hl
GM B-Body Forum, 77-79 Caprice/Impala Forum

A forum for all the owners and enthusiasts of General Motors B-Bodies from 1965-1996, but dedicated to the owners of 1977-1979 Impalas and Caprices. Join up now!


    Been a while Buick update

    Share

    hotwheelsboy28
    Junior Member
    Junior Member

    Posts : 24
    Join date : 2014-01-11
    Location : Tennessee

    Been a while Buick update

    Post  hotwheelsboy28 on Fri Jun 03, 2016 7:00 am

    But, I have been busy off and on,on my old Buick. Had a new windshield installed. Cleaned, painted my frame as far as i could reach,installed all new upper and lower front control arms (Moog) and steering linkage from Rockauto new end links and bushings for the sway bar also had new front coils installed along with my Lokar TH400 kickdown kit, got my blower motor to work on high again and my vents working right, mounted and wired my gauges finally,bought new Dynomax Super Turbos for it can't wait till my X pipe and full exhaust are installed, trunk light cruise control and the ac working again, some how with all the work me and my friends have done on it we unknowingly fixed the massive short it had, yeah! Little by little it's comming together! Very Happy
    I also installed a 120 amp alternator on the old Caprice everything is working much better now!
    avatar
    Myloth
    Forum Moderator

    Posts : 626
    Join date : 2014-06-09
    Location : At the base of the Mountain (NY) Adirondacks

    Re: Been a while Buick update

    Post  Myloth on Fri Jun 03, 2016 9:05 am

    Sounds like you have been busy indeed! Any pics to post?

    hotwheelsboy28
    Junior Member
    Junior Member

    Posts : 24
    Join date : 2014-01-11
    Location : Tennessee

    Re: Been a while Buick update

    Post  hotwheelsboy28 on Sun Jun 05, 2016 4:48 am

    Naw, no pics yet, my back is messin with me again, I've already had one surgery on it almost four years ago. I'm going to see my back Dr. Monday. I'll try to get some soon. With the new front coils I think it's a bit too high,may cut a coil off, the last time I cut two off and it was almost draggin the ground! I forgot to mention I fixed the bench seat so I can adjust it again the old "rod" broke so I went to the hardware store and bought a piece of small cable a couple heavy duty springs and a thing to adjust the tension, it works fine now. Seen that trick on youtube!

      Current date/time is Sat Aug 19, 2017 12:57 pm